Comment ajouter des emojis à Excel (et les modifier en réponse à vos données)

Excel a toujours été connu pour traiter des données complexes, produire des calculs détaillés, créer des tableaux et des graphiques dynamiques et utiliser des formules approfondies. Mais pourquoi ne pas rendre votre feuille de calcul plus amusante en utilisant des emojis dans vos formules ?

Comment ajouter des emojis à Excel (et les modifier en réponse à vos données) - %categories

Vous pouvez utiliser la mise en forme conditionnelle dans Excel pour ajouter des symboles ou des couleurs en fonction d'une valeur de cellule, mais malheureusement, cela n'offre pas l'utilisation d'émojis. Alors, pour contourner cet inconvénient plutôt gênant, voyons comment utiliser la fonction IF pour ce faire.

En savoir plus sur la fonction SI

Tout d'abord, explorons brièvement la fonction IF d'Excel, qui effectue un test logique sur une valeur de cellule pour obtenir un résultat et a la syntaxe suivante :

= SI (A,B,C)

Où A est le test logique, B est le résultat si le test est vrai et C est le résultat si le test est faux.

Dans l'exemple ci-dessous, nous voulons savoir si les employés ont atteint leur objectif de 10000 XNUMX $.

Comment ajouter des emojis à Excel (et les modifier en réponse à vos données) - %categories

Pour ce faire Peter, nous devons écrire

=SI(B2>=$C$1,"Oui","Non")

Dans la cellule C2. Si le profit de Pierre est supérieur ou égal à l'objectif, le résultat sera oui, et sinon, le résultat sera non.

Notez que nous utilisons des guillemets autour des mots « oui » et « non », car nous indiquons à Excel que les résultats seront ces chaînes de texte spécifiques (au lieu de la valeur par défaut VRAI pour un résultat positif et FAUX pour un résultat négatif). Nous utilisons également une référence absolue (symbole du dollar) pour faire référence à la cellule C1 dans notre formule IF, car nous souhaitons qu'Excel compare continuellement les gains de chaque employé à la valeur cible de cette cellule.

Lisez aussi:  Comment annuler l'ajout de personnes sur Snapchat

Nous utiliserons ensuite AutoFill dans Excel pour compléter le reste de la colonne C.

Comment ajouter des emojis à Excel (et les modifier en réponse à vos données) - %categories

Mais au lieu que le résultat soit un mot comme oui ou non, vous souhaiterez peut-être utiliser un emoji.

Comment utiliser les emojis avec la fonction IF

Pour produire des emojis à la suite d'un test logique, nous utilisons la même fonction IF :

= SI (A,B,C)

Où A est le test logique, B est l’emoji si le test est vrai et C est l’emoji si le test est faux.

En utilisant le tableau ci-dessus, nous allons à la cellule C2 et commençons la formule IF, jusqu'au point où nous ajouterons les emojis.

=SI(B2>=$C$1,"

En règle générale, pour insérer un symbole, nous nous dirigeons généralement vers l'onglet « Insérer » sur le ruban et cliquons sur « Symbole ». Cependant, lorsque vous liez une formule ou une autre valeur dans une cellule, vous remarquerez que l'icône est grisée.

Comment ajouter des emojis à Excel (et les modifier en réponse à vos données) - %categories

Nous devons donc utiliser une méthode alternative pour montrer quels emojis nous souhaitons ajouter à notre formule. Si vous utilisez un ordinateur Windows, appuyez sur Windows+. (Touche Windows et touche point). Si vous utilisez un Mac, appuyez sur Ctrl+Cmd+Espace. Cela fera apparaître une liste d'émojis que vous pouvez utiliser dans votre formule.

Comment ajouter des emojis à Excel (et les modifier en réponse à vos données) - %categories

Recherchez l'emoji que vous souhaitez afficher si le test logique est correct et cliquez dessus une fois, fermez les guillemets, ajoutez une virgule et ouvrez les guillemets suivants.

=if(B2>=$C$1,"😁","

Maintenant, utilisez le même raccourci clavier pour lancer le clavier emoji et sélectionnez l'option que vous souhaitez utiliser si le test logique est faux. Fermez ensuite les guillemets et les parenthèses et appuyez sur Entrée.

=si(B2>=$C$1,"😁","😫")

Vous verrez maintenant quels emojis apparaissent dans la cellule dans laquelle vous tapez, vous indiquant si le test logique a été rempli.

Lisez aussi:  Comment réparer le fichier PST sans ScanPST

Comment ajouter des emojis à Excel (et les modifier en réponse à vos données) - %categories

Enfin, utilisez la fonction de remplissage automatique pour compléter le reste des résultats.

Comment ajouter des emojis à Excel (et les modifier en réponse à vos données) - %categories

De plus, si vos données changent, les emoji seront automatiquement mis à jour pour indiquer si le test logique a été satisfait.

Vous savez maintenant comment insérer des emojis à l'aide de la fonction IF, pourquoi ne pas essayer Fonction Combiner SI ou utiliser d'autres fonctions logiques dans Excel ?

Vous pourriez l'aimer aussi